Personal tools

Asus UL30A

Notes about my computer.

Touchpad

The touchpad really sucks. It is at the same level as the surrounding surface and you can easily lie your hands on it to cause crazy things to happen. The <Fn-F9> doesn't work in Ubuntu (up through Maverick at least) and I found a workaround at one time for the old versions. I've simply trained my hands not to rest on the pad for now, but would always have the touchpad off if I could. Also the surface is glossy and sticky for your fingertips. It is difficult to make the cursor do what you want it to. This is the worst thing about the whole laptop

Case

The Aluminum top is nice but the interior casing is a glossy slick plastic which picks up and displays every fingerprint. Also when closed the screen edges engrave a line in the glossy casing from light scratching.

Weight and Size

This is fantastic. It is super light and small and I can pack it and take it anywhere. The real reason these are called notebooks.

Battery Life

This is really good too. I've gotten at least 6 to 8 hours on Ubuntu and longer on Windows.

Ubuntu Compatability

The F5 and F6 buttons for screen brightness didn't work out of the box with Ubuntu 10.04LTS. I followed these instructions to fix it: https://wiki.ubuntu.com/AsusUL#Screen Backlight Hotkeys.

I upgraded from Ubuntu 10.04 to 10.10 and things seemed to go good except for this error:

The following partially installed packages will be configured:
  gnome-orca python-speechd 
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Setting up python-speechd (0.7-5ubuntu3) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 2304, in 
    main()
  File "/usr/bin/pycentral", line 2298, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1501, in run
    self.options.exclude, byte_compile_default=True)
  File "/usr/bin/pycentral", line 1085, in install
    rt.byte_compile(linked_files, bc_option, exclude_regex, ignore_errors)
  File "/usr/bin/pycentral", line 231, in byte_compile
    shell=False, stdin=subprocess.PIPE)
  File "/usr/lib/python2.6/subprocess.py", line 623, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1141, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
dpkg: error processing python-speechd (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gnome-orca:
 gnome-orca depends on python-speechd (>= 0.6.2); however:
  Package python-speechd is not configured yet.
dpkg: error processing gnome-orca (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 python-speechd
 gnome-orca
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up python-speechd (0.7-5ubuntu3) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 2304, in 
    main()
  File "/usr/bin/pycentral", line 2298, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1501, in run
    self.options.exclude, byte_compile_default=True)
  File "/usr/bin/pycentral", line 1085, in install
    rt.byte_compile(linked_files, bc_option, exclude_regex, ignore_errors)
  File "/usr/bin/pycentral", line 231, in byte_compile
    shell=False, stdin=subprocess.PIPE)
  File "/usr/lib/python2.6/subprocess.py", line 623, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1141, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
dpkg: error processing python-speechd (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-orca:
 gnome-orca depends on python-speechd (>= 0.6.2); however:
  Package python-speechd is not configured yet.
dpkg: error processing gnome-orca (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-speechd
 gnome-orca
The task bar in Gnome would have issues in 10.04, such as the icons jumping around and the power button being covered up. But things seem fixed now in 10.10.
Document Actions